Cara Setting Router Mikrotik Melalui Terminal

- 7/23/2016

Cara Setting Router Mikrotik via Terminal - Pada tutorial sebelumnya saya sudah pernah membahas langkah-langkah konfigurasi dasar router mikrotik menggunakan winbox. Router mikrotik sendiri bisa diakses dan dikonfigurasi menggunakan beberapa cara, bisa dengan winbox, telnet, ssh maupun webfig.

Kalau bisa dikonfigurasi via GUI menggunakan winbox ngapain sih susah-susah konfig via CLI segala? Mungkin banyak yang akan bertanya seperti itu, tapi perlu diketahui, jika kamu adalah seorang Network Engineer / Network Administrator, maka kemampuan mengonfigurasi perangkat-perangkat jaringan dengan command line adalah salah satu skill yang mutlak harus kamu kuasai, ini dikarenakan ada beberapa kondisi di mana router mikrotik tidak dapat diremote pakai winbox, misalnya karena akses winbox (TCP 8291) ke router terblok dan sebagainya.
Cara Setting Router Mikrotik Melalui Terminal
Baca juga :

Oleh karena itu saya sangat menyarankan agar kamu mempelajari basic-basic command line yang ada pada router mikrotik, tujuannya agar kamu bisa melakukan serangkaian konfigurasi router mikrotik dengan cara mengetikkan baris-baris perintah pada terminal.

Cara Setting Router Mikrotik Lewat Terminal

Pada tutorial ini kita akan belajar mengkonfigurasi router mikrotik sebagai internet gateway dengan command line interface (CLI). Router mikrotik yang saya pakai yaitu RB951Ui-2HnD dengan RouterOS versi 6.30 dan terhubung dengan modem ONT Huawei HG8245A, berikut adalah kondisi lebih detil mengenai jaringan saya.

  • Ether1 mikrotik terhubung ke modem ISP.
  • Ether1 mikrotik mendapatkan IP 192.168.200.5/24 dan gateway 192.168.200.1. 
  • Ether2 mikrotik terhubung ke jaringan lokal dengan IP 192.168.100.1/24.
  • Router mikrotik menjalankan DHCP Server di ether2 yang mengarah ke LAN.

Jika kondisi di jaringan kamu berbeda, silahkan disesuaikan. Untuk mengkonfigurasi router mikrotik dengan CLI, kita bisa login ke router mikrotik baik via Telnet, SSH, maupun melalui New Terminal yang ada pada winbox.

1. Setting IP Address di Router Mikrotik

Untuk menambahkan IP address pada masing-masing interface mikrotik silahkan kamu ketikkan perintah di bawah ini, untuk IP address dan interfacenya silahkan disesuaikan.
/ip address add address=192.168.200.5/24 interface=ether1 disabled=no comment="WAN"
/ip address add address=192.168.100.1/24 interface=ether2 disabled=no comment="LAN"
Result :
Cara Setting Router Mikrotik Melalui Terminal

2. Menambahkan Default Gateway di Router Mikrotik

Setelah berhasil menambahkan IP address pada masing-masing interface, tahap selanjutnya kamu harus menambahkan default gateway agar router mikrotik bisa terhubung ke gateway (pada contoh ini gateway-nya yaitu modem ONT Huawei dengan IP address 192.168.200.1).
/ip route add dst-address=0.0.0.0/0 gateway=192.168.200.1
Result :
Cara Setting Router Mikrotik Melalui Terminal

3. Setting DNS di Router Mikrotik

Agar router mikrotik bisa terhubung ke internet, kamu perlu menambahkan DNS, untuk DNSnya sendiri kamu bisa pakai Public DNS milik Google, jalankan perintah berikut untuk menambahkan entri DNS pada router mikrotik.
/ip dns set servers=192.168.200.1,8.8.8.8 allow-remote-requests=yes   
Result :
Cara Setting Router Mikrotik Melalui Terminal

4. Menambahkan NAT Masquerade di Router Mikrotik

Agar PC/Laptop client di jaringan lokal yang ada di bawah router mikrotik bisa terhubung ke internet, maka kita perlu menambahkan rule NAT (Network Address Translation) di menu IP > Firewall > NAT.
/ip firewall nat add chain=srcnat src-address=192.168.100.0/24 action=masquerade
Result :
Cara Setting Router Mikrotik Melalui Terminal

5. Setting DHCP Server di Router Mikrotik

DHCP Server berfungsi untuk memberikan IP address ke client di jaringan lokal secara otomatis, tujuannya agar kita tidak perlu repot setting IP secara manual satu-persatu di setiap PC client, ketikkan perintah ip dhcp-server setup kemudian tentukan interface pada parameter dhcp server interface, selanjutnya tinggal tekan tombol Enter saja sampai selesai.
[dodiventuraz@MikroTik] > ip dhcp-server setup
Select interface to run DHCP server on 

dhcp server interface: ether2 
Select network for DHCP addresses 

dhcp address space: 192.168.100.0/24 
Select gateway for given network 

gateway for dhcp network: 192.168.100.1
Select pool of ip addresses given out by DHCP server 

addresses to give out: 192.168.100.2-192.168.100.254
Select DNS servers 

dns servers: 192.168.200.1,8.8.8.8 
Select lease time 

lease time: 10m 
Result :
Cara Setting Router Mikrotik Melalui Terminal

6. Mengubah Identity Router Mikrotik

Secara default identitas atau ID router mikrotik hanya akan ditulis dengan MikroTik saja, kamu bisa menggantinya dengan mengetikkan perintah berikut.
/system identity set name=dodiventuraz.blogspot.co.id
Result :
Cara Setting Router Mikrotik Melalui Terminal
Sampai tahap ini kamu sudah berhasil mengkonfigurasi router mikrotik agar bisa terhubung ke internet dan juga terhubung dengan PC client yang ada di jaringan lokal dengan command line, mudah bukan?
Advertisement
 

Start typing and press Enter to search