Tutorial Cara Konfigurasi VLAN di Router Mikrotik dan Switch Cisco

- 6/19/2017
Tutorial Cara Konfigurasi VLAN di Mikrotik - VLAN (Virtual LAN) adalah sebuah metode yang digunakan untuk mendistribusikan beberapa segment jaringan (yang berbeda) secara logic pada sebuah device (Router, Switch) yang memiliki jumlah port ethernet yang terbatas.

Dengan adanya VLAN kita bisa membuat segment LAN sebanyak 4095 segment pada sebuah interface / port ethernet, dalam dunia networking terdapat 2 jenis VLAN yaitu VLAN Tagged dan VLAN Untagged. Apa perbedaan dari kedua jenis VLAN tersebut ?

Perbedaan VLAN Tagged dan VLAN Untagged

VLAN Tagged adalah Core Port atau biasa dikenal juga dengan VLAN Trunk, fungsinya yaitu untuk mendistribusikan beberapa informasi VLAN dalam satu port ethernet yang sama, sedangkan VLAN Untagged adalah Edge Port atau biasa disebut dengan VLAN Access yang hanya membawa satu informasi VLAN dalam sebuah port ethernet. Interface / port ethernet yang diset sebagai VLAN Access (Untagged) adalah port yang langsung terhubung ke masing-masing node seperti PC, Laptop, Printer dan lain-lain.

Itulah sedikit gambaran mengenai VLAN, pada artikel kali ini saya tidak akan membahas materi VLAN secara detail, melainkan hanya akan lebih menekankan bagaimana cara konfigurasi VLAN pada router mikrotik, kalau tidak ada halangan insyaallah akan saya posting artikel yang membahas secara khusus tentang VLAN.

Cara Membuat VLAN di Router Mikrotik

Pada artikel kali ini saya akan membagikan tutorial bagaimana membuat VLAN pada router mikrotik, akan ada 2 VLAN ID yang memiliki segmen IP yang berbeda untuk kemudian didistribusikan ke Switch Cisco dan selanjutnya diteruskan oleh Switch ke masing-masing user, sebagai gambaran berikut topology yang saya gunakan.
Tutorial Cara Konfigurasi VLAN di Mikrotik
Ada 2 (dua) VLAN yang akan dibuat pada router mikrotik, yaitu VLAN 10 dengan segment IP 192.168.10.1/24 dan VLAN 20 dengan segment IP 192.168.20.1/24, kedua VLAN tersebut akan ditrunk melalui port ether2 mikrotik ke port  fa0/0 switch cisco.

Kemudian dari switch cisco VLAN 10 akan diteruskan melalui port fa0/1 dan VLAN 20 akan diteruskan melalui port fa0/2.

Untuk mempraktekkan tutorial ini kamu bisa mencobanya menggunakan network simulator GNS3 dan pastikan topology yang dipakai sudah sesuai dengan topology yang ada pada tutorial ini. Sekarang kita lanjut ke tahap konfigurasi.

Silahkan login ke router mikrotik bisa menggunakan winbox, SSH maupun Telnet, kemudian ketikkan perintah berikut ini di terminal mikrotik untuk membuat masing-masing VLAN.
/interface vlan add name=vlan10-marketing vlan-id=10 interface=ether2 use-service-tag=no
/interface vlan add name=vlan20-finance vlan-id=20 interface=ether2 use-service-tag=no
Setiap VLAN yang sudah dicreate akan muncul di menu /interface router mikrotik, kamu bisa mengeceknya dengan mengetikkan perintah /interface print atau klik menu Interfaces jika menggunakan winbox.

Tahap berikutnya adalah menambahkan IP address ke masing-masing interface VLAN yang sudah dibuat, ketikkan perintah berikut di terminal mikrotik.
/ip address add address=192.168.10.1/24 interface=vlan10-marketing disabled=no
/ip address add address=192.168.20.1/24 interface=vlan20-finance disabled=no
Sampai disini kita sudah selesai membuat VLAN pada router mikrotik dan juga menambahkan alamat IP untuk masing-masing VLANnya.

Cara Membuat VLAN di Switch Cisco

Selanjutnya kamu harus membuat VLAN 10 dan VLAN 20 pada switch cisco, silahkan login ke switch cisco kemudian jalankan perintah berikut untuk menambahkan VLAN.
SW-Cisco#vlan database 
SW-Cisco(vlan)#vlan 10 name Marketing
VLAN 10 added:
    Name: Marketing
SW-Cisco(vlan)#vlan 20 name Finance
VLAN 20 added:
    Name: Finance
SW-Cisco(vlan)#exit
APPLY completed.
Exiting....
SW-Cisco#
Selanjutnya assign VLAN ke masing-masing port di switch cisco dengan menjalankan perintah-perintah berikut.
SW-Cisco#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
SW-Cisco(config)#interface fastEthernet 0/0
SW-Cisco(config-if)#switchport mode trunk
SW-Cisco(config-if)#no shutdown 
SW-Cisco(config-if)#exit
SW-Cisco(config)#interface fastEthernet 0/1
SW-Cisco(config-if)#switchport mode access 
SW-Cisco(config-if)#switchport access vlan 10
SW-Cisco(config-if)#description VLAN Marketing
SW-Cisco(config-if)#no shutdown 
SW-Cisco(config-if)#exit
SW-Cisco(config)#interface fastEthernet 0/2
SW-Cisco(config-if)#switchport mode access 
SW-Cisco(config-if)#switchport access vlan 20
SW-Cisco(config-if)#description VLAN Finance
SW-Cisco(config-if)#no shutdown 
SW-Cisco(config-if)#exit
SW-Cisco(config)#exit
Setelah selesai membuat VLAN dan assign VLAN ke masing-masing port, kita lakukan verifikasi dengan perintah show interface status pada switch cisco seperti gambar di bawah, pastikan status port nya sudah connected.
Melihat status interface pada switch cisco
Membuat VLAN di mikrotik sudah, di switch juga sudah, sekarang silahkan assign IP address di masing-masing PCnya.

Kemudian test PING dari masing-masing PC ke gateway, pastikan hasilnya sudah reply, apabila setiap PC sudah bisa PING ke gateway maka akan muncul di menu ARP router mikrotik seperti gambar di bawah ini.
Melihat ARP pada router mikrotik
Itulah langkah-langkah mengkonfigurasi VLAN pada router mikrotik dan switch cisco. Jika ada pertanyaan atau ada pembahasan pada artikel ini yang susah dipahami, silahkan tanyakan melalui kolom komentar.

Baca juga :

Akhir kata, semoga bermanfaat dan terimakasih.

Advertisement
 

Start typing and press Enter to search