Tutorial Cara Konfigurasi Router Cisco Sebagai Internet Gateway

- 6/30/2018
Tutorial Cara Konfigurasi Router Cisco Sebagai Internet Gateway - Pada postingan sebelumnya kita sudah belajar cara mengkoneksikan router cisco ke jaringan internet, dikarenakan saya tidak memiliki perangkat cisco yang asli, jadinya saya simulasikan saja menggunakan software GNS3, bagi sobat yang belum membacanya silahkan klik link tautan dibawah ini.


Apabila router cisco sudah berhasil terkoneksi ke jaringan internet, langkah berikutnya adalah menghubungkan jaringan lokal yang berada dibawah router ke router itu sendiri, istilah lainnya adalah menjadikan router cisco sebagai internet gateway. Namun, pada tutorial ini saya akan jelaskan step-stepnya dari awal sampai PC client dibawah router dapat terkoneksi ke internet.
Tutorial Cara Konfigurasi Router Cisco Sebagai Internet Gateway
Tujuannya agar jaringan lokal yang berada dibawah router dapat terhubung ke internet, tahap konfigurasinya yaitu kurang lebih sebagai berikut.

1. Konfigurasi alamat IP pada masing-masing interface router
2. Konfigurasi default gateway (route) pada router
3. Konfigurasi DNS resolver pada router agar dapat mengenali host yang ada di internet
4. Konfigurasi NAT (Network Address Translation)
5. Konfigurasi alamat IP pada PC client
6. Pengujian

Cukup simple bukan ? sobat bisa mempraktekkan tutorial ini pada jaringan yang sebenarnya atau kalau tidak memiliki perangkat asli bisa memakai network simulator GNS3 seperti saya. Ya, tutorial ini saya buat menggunakan aplikasi GNS3.

Namun Cisco IOS Router tidak terinstall di GNS3 secara default, sehingga kita harus menginstalnya secara manual, panduannya bisa sobat baca pada postingan sebelumnya disini (baca : tutorial cara install Cisco IOS router di GNS3).

Cara Setting Router Cisco Sebagai Internet Gateway

Sebelum lanjut ke proses konfigurasi, berikut topologi dan juga pengalamatan IP yang saya gunakan, untuk topologinya saya buat sesederhana mungkin agar sobat yang baru belajar dapat memahaminya dengan baik. 
Tutorial Cara Konfigurasi Router Cisco Sebagai Internet Gateway

1. Konfigurasi IP Address

Klik kanan router lalu pilih Console, kemudian lakukan konfigurasi alamat IP pada masing-masing interface router, yaitu interface fa0/0 dengan alamat IP 192.168.122.2/24 untuk WAN dan juga interface fa0/1 dengan alamat IP 192.168.133.1/24 untuk LAN.
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.122.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fa0/1
R1(config-if)#ip address 192.168.133.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
Cek IP address dan juga status port apakah statusnya sudah up atau masih down dengan perintah berikut.
R1#show ip interface brief 
Interface                  IP-Address      OK? Method Status    Protocol
FastEthernet0/0            192.168.122.2   YES manual up        up      
FastEthernet0/1            192.168.133.1   YES manual up        up      
R1#

2. Konfigurasi Default Gateway (Route)

Agar router dapat terkoneksi ke gateway, dalam hal ini yaitu modem dari ISP, maka kita wajib menambahkan entry routing pada router.
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.122.1
Cek apakah entry routing sudah berhasil ditambahkan pada tabel routing di router atau belum.
R1(config)#do sh ip route                        
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.122.1 to network 0.0.0.0

C    192.168.122.0/24 is directly connected, FastEthernet0/0
C    192.168.133.0/24 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [1/0] via 192.168.122.1
R1(config)#   
Dari table routing diatas bisa dilihat bahwa entri routing yang baru saja kita buat sudah diberhasil ditambahkan kedalam tabel routing pada router, perhatikan entri routing dengan tanda (S*) yang berarti entri routing tersebut bersifat statik (dibuat secara manual, bukan dynamic).

3. Konfigurasi DNS Resolver

Agar router dapat mengenali hostname dan juga alamat domain yang ada di internet, maka kita perlu mengkonfigurasi DNS Resolver pada router, tanpa adanya DNS Resolver, router hanya akan mengenali alamat IP saja.
R1(config)#ip domain lookup 
R1(config)#ip name-server 8.8.8.8
R1(config)#ip name-server 8.8.4.4
Apabila alamat IP, default gateway, dan juga DNS pada router sudah dikonfigurasi, sekarang kita coba lakukan test ping dari router ke alamat IP gateway dan juga situs yang ada di internet.
R1(config)#do ping 192.168.122.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.122.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/28 ms
R1(config)#do ping www.tutorialjaringan.com
Translating "www.tutorialjaringan.com"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.26.83, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/28 ms
R1(config)#
Dari hasil test ping diatas, ternyata router sudah berhasil ping reply ke alamat IP gateway (ISP) dan juga situs internet.

4. Konfigurasi NAT (Network Address Translation)

Berikutnya adalah mengkonfigurasi Network Address Translation (NAT) masquerade agar client yang berada dibawah router dapat terhubung ke jaringan internet, tanpa adanya konfigurasi NAT maka client dibawah router tidak akan dikenali oleh internet, karena client dibawah router menggunakan alamat IP Private bukan alamat IP Publik.
R1(config)#access-list 1 permit 192.168.133.0 0.0.0.255
R1(config)#ip nat inside source list 1 interface fa0/0 overload
R1(config)#interface fa0/0
R1(config-if)#ip nat outside
R1(config-if)#exit
R1(config)#interface fa0/1
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#
Dengan begitu maka client dibawah router sudah bisa mengakses internet, tahap berikutnya yaitu melakukan konfigurasi alamat IP pada PC client, pada tutorial ini untuk alamat IP yang dipasang di PC client yaitu alamat IP Static sehingga perlu dikonfigurasi secara manual.

5. Konfigurasi Alamat IP Client

Apabila sobat mempraktekkan tutorial ini menggunakan real device dan PC Client menggunakan operating system Windows, sobat bisa mengkonfigurasi alamat IP melalui Control Panel -> Network and Sharing Center -> Change adapter settings, selanjutnya saya rasa sobat sudah paham sendiri.

Dikarenakan pada tutorial ini saya mensimulasikannya menggunakan GNS3, maka PC clientnya saya memakai VPCS (Virtual PC Simulator) yaitu end device yang sudah tersedia pada GNS3, untuk mengkonfigurasi alamat IP pada VPCS caranya klik kanan VPCS lalu pilih Console, kemudian ketikkan perintah berikut.
PC-1> ip 192.168.133.2 255.255.255.0 192.168.133.1
Checking for duplicate address...
PC1 : 192.168.133.2 255.255.255.0 gateway 192.168.133.1

PC-1> ip dns 8.8.8.8

PC-1> show ip

NAME        : PC-1[1]
IP/MASK     : 192.168.133.2/24
GATEWAY     : 192.168.133.1
DNS         : 8.8.8.8  
MAC         : 00:50:79:66:68:00
LPORT       : 10008
RHOST:PORT  : 127.0.0.1:10009
MTU:        : 1500

PC-1> 

6. Pengujian

Sampai disini konfigurasi sudah selesai, tahap terkahir yaitu pengujian untuk memastikan client dibawah router sudah berhasil terkoneksi ke internet, lakukan test ping ke alamat IP gateway dan juga situs internet.
PC-1> ping 192.168.133.1
84 bytes from 192.168.133.1 icmp_seq=1 ttl=255 time=291.810 ms
84 bytes from 192.168.133.1 icmp_seq=2 ttl=255 time=220.105 ms
84 bytes from 192.168.133.1 icmp_seq=3 ttl=255 time=6.386 ms
84 bytes from 192.168.133.1 icmp_seq=4 ttl=255 time=5.731 ms
84 bytes from 192.168.133.1 icmp_seq=5 ttl=255 time=5.360 ms

PC-1> ping www.google.com
www.google.com resolved to 74.125.24.104
84 bytes from 74.125.24.104 icmp_seq=1 ttl=40 time=59.491 ms
84 bytes from 74.125.24.104 icmp_seq=2 ttl=40 time=35.469 ms
84 bytes from 74.125.24.104 icmp_seq=3 ttl=40 time=136.656 ms
84 bytes from 74.125.24.104 icmp_seq=4 ttl=40 time=226.599 ms
84 bytes from 74.125.24.104 icmp_seq=5 ttl=40 time=45.695 ms
Dari hasil test ping diatas ternyata PC client sudah berhasil ping reply ke alamat IP gateway dan juga google.com, apabila sudah seperti itu berarti kita sudah berhasil mengkonfigurasi router cisco sebagai internet gateway.

Demikian tutorial sederhana ini, semoga bermanfaat & terima kasih.

Advertisement
This Newest Prev Post
 

Start typing and press Enter to search