Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

- 1/15/2019
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik - Redistribute adalah metode untuk membagikan informasi routing yang ada di dalam routing tabel sebuah router ke router lain melalui proses pertukaran routing update.

Metode redistribute biasanya diterapkan pada jaringan yang di dalamnya terdapat beberapa teknik routing yang berbeda, tujuannya agar host-host yang berada dalam jaringan dengan berbeda teknik routing dapat saling berkomunikasi, contohnya adalah Redistribute static routing pada routing RIP yang sudah pernah saya bahas beberapa waktu lalu.

Atau bisa juga redistribute default route pada jaringan yang menerapkan routing OSPF seperti yang akan kita bahas pada kesempatan kali ini. Default route atau biasa disebut default gateway, adalah entri routing yang dipakai oleh router sebagai acuan untuk menuju ke jaringan luar atau ke internet.

Jadi tujuan dari redistribute default route adalah untuk membagikan informasi entri routing default gateway sebuah router ke router lain yang masih berada dalam jaringan OSPF agar kita sebagai administrator tidak perlu repot-repot membuat entri routing default gateway pada masing-masing router.

Tutorial ini merupakan lanjutan dari tutorial Konfigurasi routing OSPF Multi Area yang sudah saya publish sebelumnya, sehingga untuk topologi yang digunakan pun masih sama.

Cara Setting Redistribute Default Route di OSPF

Pada tutorial sebelumnya kita sudah belajar bagaimana mengkonfigurasi routing OSFP Multi Area pada router mikrotik untuk menghubungkan beberapa network yang berbeda, namun pada tutorial tersebut kita belum melakukan konfigurasi agar semua network dapat terhubung ke jaringan luar atau internet.
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik
Nah pada kesempatan kali ini kita akan belajar bagaimana agar semua router dan host yang ada pada jaringan OSPF dapat terhubung ke jaringan internet dengan teknik redistribute default route.

Saya asumsikan kamu sudah melakukan konfigurasi routing OSPFnya, sehingga tabel routing pada masing-masing router akan terlihat seperti ini.

Tabel Routing Router R1
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R2
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R3
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R4
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R5
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik
Dari tabel routing router R1 sampai router R5 di atas, bisa dilihat bahwa semuanya belum memiliki entri default route / default gateway, sehingga semua router belum bisa terhubung ke network luar atau internet.

Dengan kondisi banyak router seperti ini bisa saja kita menambahkan entri default route pada masing-masing router, tapi akan cukup merepotkan, untuk itu kita hanya perlu melakukan konfigurasi default route di router R1 yang bertugas sebagai internet gateway, kemudian dari router R1 kita lakukan redistribute default route ke semua router yang ada di jaringan OSFP.

Sehingga nantinya kita tidak perlu lagi menambahkan entri default route pada tabel routing semua router selain router R1. Oh ya, pada tutorial sebelumnya kita hanya mengkonfigurasi routing OSPFnya saja & belum menambahkan IP pada interface ether1 di router R1 untuk menjangkau network luar (internet).

Untuk itu kita perlu menambahkan IP Address 192.168.122.2/24 pada interface ether1 di router R1 sesuai dengan pengalamatan IP pada topologi di atas. Selain IP, kita juga harus menambahkan DNS dan juga entri default route / default gateway pada router R1.

[admin@R1] > /ip address add address=192.168.122.2/24 interface=ether1
[admin@R1] > /ip dns set servers=8.8.8.8,8.8.4.4
[admin@R1] > /ip route add gateway=192.168.122.1

Agar network yang ada di bawah router R1 dapat terkoneksi ke internet, kita harus menambahkan rule NAT masquerade.

[admin@R1] > /ip firewall nat add action=masquerade chain=srcnat out-interface=ether1

Setelah itu lakukan redistribute default route di router R1.

[admin@R1] > /routing ospf instance set 0 distribute-default=always-as-type-1

Kemudian kita cek tabel routing di semua router, hasilnya akan terlihat seperti ini.

Tabel Routing Router R1
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R2
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R3
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R4
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik

Tabel Routing Router R5
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik
Setelah dilakukan konfigurasi redistribute default route pada router R1, alhasil sekarang semua router sudah memiliki entri default route untuk menjangkau semua network yang ada di internet.

Kamu bisa melihat tabel routing masing-masing router saat ini sudah memiliki entri default route dengan flag ADo (Active, Dynamic, Ospf). Artinya, entri routing tersebut dibuat secara otomatis oleh routing OSPF.

Sampai disini konfigurasi redistribute default route pada routing OSPF sudah selesai, namun tujuan utama dari konfigurasi default route adalah agar semua network yang ada bisa terkoneksi ke internet, oleh karena itu jangan lupa untuk melakukan konfigurasi DNS dan juga NAT masquerade pada semua router.

[admin@R2] > /ip dns set servers=8.8.8.8,8.8.4.4
[admin@R2] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

[admin@R3] > /ip dns set servers=8.8.8.8,8.8.4.4
[admin@R3] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

[admin@R4] > /ip dns set servers=8.8.8.8,8.8.4.4
[admin@R4] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

[admin@R5] > /ip dns set servers=8.8.8.8,8.8.4.4
[admin@R5] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Berikut hasil akhir test ping dari PC1 dan PC3 ke situs google.
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik
Tutorial Redistribute Default Route Pada Routing OSPF di Mikrotik
Hasil test ping di atas menunjukkan bahwa komputer user sudah bisa terhubung dengan jaringan internet, sampai disini konfigurasi redistribute default route pada routing OSPF sudah berhasil.

Demikian tutorial kali ini, semoga bermanfaat.

Advertisement
 

Start typing and press Enter to search