Tutorial Cara Drop Port Scanner di Mikrotik

- 6/10/2016
Cara Blok Port Scanner di Router Mikrotik -  Pada tutorial mikrotik kali ini, kita akan belajar salah satu materi keamanan jaringan pada router mikrotik. Yaitu materi firewall, dimana pada artikel ini saya akan menjelaskan langkah-langkah preventif mengamankan router mikrotik menggunakan filter rule untuk mendeteksi dan memblokir serangan port scanning.

Pengertian Port Scanner

Port scanner adalah adalah sebuah aplikasi yang dirancang untuk mengetahui port yang terbuka pada server atau host, bagi seorang administrator jaringan, tool port scanner bisa digunakan untuk memverifikasi keamanan jaringan yang dikelola, namun bagi seorang attacker, port scanner justru bisa digunakan sebagai tools untuk mengidentifikasi service yang berjalan pada server lalu memanfaatkan port tersebut untuk keperluan eksploitasi.
RouterOS mikrotik memiliki fitur firewall (filter rule) yang bisa kita manfaatkan untuk keperluan melakukan drop port scanner ini agar router kita lebih aman.

Cara Drop Port Scanner di Mikrotik

Setelah mengetahui bahaya dari port scanner ini, sebagai seorang administrator jaringan sebaiknya kita melakukan filtering untuk menangkal port scanner ini agar router yang kita kelola bisa lebih aman dari attacker yang tidak bertanggung jawab.

Update !!!
Jika di jaringan kamu ada salah satu PC/Laptop yang menginstall software monitoring The Dude, maka IP PC tersebut harus diallow agar tidak terblok oleh rule drop port scanner ini.

Untuk melakukan filtering port scanner pada router mikrotik pun cukup mudah, pertama silahkan login ke mikrotik baik menggunakan winbox, SSH, ataupun Telnet. Kalau kamu login dengan winbox silahkan klik menu New Terminal kemudian copy-paste script di bawah ini pada terminal mikrotik.
/ip firewall filter
add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment=\
    "Add TCP Port Scanners to List" protocol=tcp psd=21,3s,3,1

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP FIN Stealth scan" \
    protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP SYN/FIN scan" protocol=\
    tcp tcp-flags=fin,syn

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP SYN/RST scan" protocol=\
    tcp tcp-flags=syn,rst

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP FIN/PSH/URG scan" \
    protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="ALL/ALL TCP Scan" protocol=\
    tcp tcp-flags=fin,syn,rst,psh,ack,urg

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP NULL scan" protocol=tcp \
    tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg

add action=drop chain=input comment="Drop All Port Scanners" \
    src-address-list=port_scanners
Kalau sudah selesai, maka hasilnya akan seperti ini, jika ada aktifitas port scanning terhadap router mikrotik kita, maka akan muncul counters traffic dalam hitungan bytes di menu IP > Firewall > Filter Rules.
Tutorial Cara Drop Port Scanner di Mikrotik
Setiap IP attacker yang berusaha melakukan port scanning ke router mikrotik, maka otomatis akan masuk ke Address List yang sudah kita tentukan tadi yaitu port_scanner, contohnya bisa kamu lihat pada screenshoot di bawah.
Tutorial Cara Drop Port Scanner di Mikrotik
Setiap IP attacker yang melakukan port scanning terhadap mikrotik akan masuk ke address list selama 2w (14 hari) dan selanjutnya akan didrop oleh rules yang paling bawah, sehingga IP tersebut tidak akan bisa melakukan scanning prot ke router mikrotik kita lagi.

Tapi bagaimana kalau IP attackernya sudah tidak dikarantina lagi di address list dan melakukan port scanning lagi? Maka akan masuk lagi ke address list dan didrop lagi oleh rules tersebut, begitu dan begitu seterusnya selama kamu tidak melepas rule filternya. 

Baca juga : Mengenal jenis-jenis service pada router mikrotik

Akhir kata, semoga tutorial sederhana ini bisa bermanfaat untuk kita semua agar bisa mengamankan router mikrotik yang ada di jaringan, terimakasih.

Advertisement
 

Start typing and press Enter to search